Command not found in container

Hello there.

So I’m trying to use golangci-lint for one of my go project. What I did before was running go get and waiting for it to install properly. But then I saw that they published a Docker image, so I’m trying to use that with drone.

    image: "golangci/golangci-lint:v1.11.3"
    pull: true
      - golangci-lint run

Thing is, when I run drone exec it works just fine. But when I’m trying to push that, I’m facing this:

/bin/sh: 17: golangci-lint: not found

I also tried different approach, changing the command to $${GOPATH}/bin/golangci-lint (since this docker image has been built using go as its base image), the same error message appeared: /bin/sh: 17: /go/bin/golangci-lint: not found

I don’t understand why that happens. Again, drone exec works just fine.
Could someone help me ?

Nevermind. Obviously I found out what was going on right after posting that message.
Turns out, my workspace value was overriding the one used by the golangci-lint’s docker image (/go) so it was not accessible. Solution was simply to change the base workspace.