Can't run drone/drone:0.9.0-alpha.1 for gitlab

I can’t see anything when I open the, then I open devtools and find a request failed: /api/user/repos?latest=true status code is 401 and response is {"message":"Unauthorized"}

I have tried 3 time both failed follow the documnet, which step I do wrong ?

docker run \
  --volume=/var/run/docker.sock:/var/run/docker.sock \
  --volume=/var/lib/drone:/data \
  --env=DRONE_TLS_AUTOCERT=true \
  --env=DRONE_GITLAB_CLIENT_ID=*********** \
  --env=DRONE_GITLAB_CLIENT_SECRET=*************** \ \
  --env=DRONE_SERVER_PROTO=http \
  --env=DRONE_PRIVATE_MODE=false \
  --env=DRONE_LOGS_DEBUG=true \
  --publish=80:80 \
  --publish=443:443 \
  --rm -ti \
  --name=drone \

drone server log

{"level":"debug","ip":"","path":"/api/user/repos?latest=true","method":"GET","request_id":"be40m1er5mqoej24mq1g","time":"2018-08-30T15:19:33Z","message":"authentication required"}
{"level":"debug","ip":"","path":"/api/user/repos?latest=true","method":"GET","request_id":"be40m1er5mqoej24mq1g","time":"2018-08-30T15:19:33Z","message":"guest access"}
{"level":"debug","ip":"","path":"/api/stream","method":"GET","request_id":"be40m1er5mqoej24mq20","time":"2018-08-30T15:19:33Z","message":"event stream opened"}

Tried yesterday, it didn’t worked too.

Opened, it does auth but comes back to and stays syncing forever.

It seems to me that the backend changed but the front end still needs to update.

There was a bug in our GitLab implementation. It was using the endpoint to sync the repository list, but was missing membership=true which was causing the synchronization to block. So it should work if you pull the latest 0.9-alpha.1

In terms of the above example, I do see a configuration issue. The DRONE_TLS_AUTOCERT us set to true and enables SSL with Let’s Encrypt. The DRONE_SERVER_PROTO, however, is set to http instead of https. Do you mean to disable Lets Encrypt? You can read more about the configuration parameters at the bottom of the GitLab install page.

docker run \
  --volume=/var/run/docker.sock:/var/run/docker.sock \
  --volume=/var/lib/drone:/data \
- --env=DRONE_TLS_AUTOCERT=true \
+ --env=DRONE_TLS_AUTOCERT=false \
  --env=DRONE_GITLAB_CLIENT_ID=xxxxxxxx \
  --env=DRONE_GITLAB_CLIENT_SECRET=xxxxxxx \ \
  --env=DRONE_SERVER_PROTO=http \

Now I can’t login by direct use 0.8.6 mysql, debug info :

{"level":"error","ip":"","path":"/login?code=xxxx&state=xxxx","method":"GET","request_id":"xxxxxxxxx","login":"shynome","error":"Error 1054: Unknown column 'user_machine' in 'field list'","time":"2018-08-31T05:31:54Z","message":"cannot select user"}

Use a new sqlite db , it work . what I need to do ?

I found problem is I use a wrong callback url for 0.8.6, so I create a new gitlab application to solve it and use the callback url of 0.9.0 is http(s)://