Cannot start on Docker for Mac due to symlinking

Hello! I’m trying to get drone up and running with Docker for Mac. I’m getting this error when running drone as per the setup guide:

$ sudo docker run --volume /var/lib/drone:/var/lib/drone --volume /var/run/docker.sock:/var/run/docker.sock --env-file /etc/drone/dronerc --restart=always --publish=80:8000 --detach=true --name=drone drone/drone:0.4
docker: Error response from daemon: Mounts denied: 
The path /var/lib/drone
is not shared from OS X and is not known to Docker.
You can configure shared paths from Docker -> Preferences... -> File Sharing.
See for more info.

On mac, /var is symlinked to /private/var. As per the defaults, /private is setup as a shared directory, however, it looks like docker doesn’t walk symlinks.

I tried directly mounting /private/var/lib/drone instead, which manages to get through docker run, but then just gives a different error. Maybe it’s unrelated though:

$ sudo docker logs drone 
time="2016-12-07T01:10:34Z" level=error msg="unable to open database file" 
time="2016-12-07T01:10:34Z" level=fatal msg="database ping attempts failed" 
time="2016-12-07T01:11:06Z" level=error msg="unable to open database file" 
time="2016-12-07T01:11:06Z" level=fatal msg="database ping attempts failed" 

the server installation instructions are intended for production installs on Linux servers. If you are running on OSX for evaluation or development purposes, I recommend not using /var/lib/drone in this case. When I run on OSX I use $HOME/drone:/var/lib/drone

Got it. That might be a good caveat in the documentation.