Authentication error publish docker container to

Hi there,
I try to publish to when my local gitea repository gets updated. I have added secrets in the UI but I get this message in the console:

time="2021-11-08T20:38:33.745829314Z" level=error msg="Handler for POST /v1.41/auth returned error: Get \"\": authorization server did not include a token in the response"

And my pipeline looks like this=

kind: pipeline

name: lunchscraper

type: docker


  - name: build

    image: node:14-alpine

    user: root


      - "npm install --production"

  - name: publish

    image: plugins/docker



        from_secret: docker_username


        from_secret: docker_password

      repo: ""        

      registry: ""

      auto_tag: true


The docker plugins executes a standard docker login command to authenticate with your registry. This error indicates docker tried to login to your registry ( but the registry returned an invalid response (no token in the response). I have not seen this error before, but since it comes from docker and indicates a problem with the registry response, you may want to consider reaching out to your registry admin for support.

Also you may have some luck googling the error. I did a quick search and other people get this same error message from even when they are not using Drone. For example,

1 Like

thank you @bradrydzewski for your answer, I tested to push to gitlab instead and it works flawless :+1: