Accessing from selenium service a nginx server in pipeline step

I have a pipeline with a selenuim service. Look the code below:

      image: <custom_image>
      group: tests
      name: sandbox
        - bash -c "cd /app/tests && /app/vendor/bin/codecept run acceptance -v -f -c codeception/dev/ sp/ --env dev --xml=/app/tests/codeception/_log/dev.sp.acceptance.xml"
        - bash -c "cd /app/tests && /app/vendor/bin/codecept run acceptance -v -f -c codeception/dev/ llc/ --env dev --xml=/app/tests/codeception/_log/dev.sp.acceptance.xml"
        branch: [yayurist-dev, sberbank-dev, root, docker]
        event: [push, pull_request]push, pull_request]
      image: selenium/standalone-chrome

In my custom image I have Nginx on port 80 and with option in vritual host server_name: sandbox. When I run acceptance tests I get error in Chrome connections refiused to sandbox.

The question How I can access the sandbox from webdriver service

Here is a working Selenium example you can use for reference

Thanks for fast reponse. I’ve checked to the reference example. I have the same settings but Chrome still show connection refused. Look at the screenshot. In the screenshot I’am accessing another step in the pipeline. May be is it dictated by that I’m running step sandbox and sp in parallel?

Before that I’ve had step with name app and I’ve figured out the Chrome automatically redirect http://app to https://app also as all TLD .dev and http://dev/.

Is ther way to connect selenium and image and debug?

@bradrydzewski Any suggestions?

I’m sorry. I forgot to start nginx before test. The problem is solved